What’s Vulnerable › Vulnerabilities

CVE-2021-33829

Description

A cross-site scripting (XSS) vulnerability in the HTML Data Processor in CKEditor 4 4.14.0 through 4.16.x before 4.16.1 allows remote attackers to inject executable JavaScript code through a crafted comment because --!> is mishandled.

Affected products

How to fix

Upgrade to a fixed version: ckeditor4 4.16.1; Drupal 8.9.16, 9.0.14, 9.1.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-33829 or the next vulnerability affects your stack