What’s Vulnerable › Vulnerabilities

CVE-2021-33909

Description

fs/seq_file.c in the Linux kernel 3.16 through 5.13.x before 5.13.4 does not properly restrict seq buffer allocations, leading to an integer overflow, an Out-of-bounds Write, and escalation to root by an unprivileged user, aka CID-8cae8cd89f05.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.13, 4.14.240, 4.19.198, 4.4.276. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-33909 or the next vulnerability affects your stack