What’s Vulnerable › Vulnerabilities
CVE-2021-33912
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-19 · updated 2026-06-17
- Weakness: CWE-787
Description
libspf2 before 1.2.11 has a four-byte heap-based buffer overflow that might allow remote attackers to execute arbitrary code (via an unauthenticated e-mail message from anywhere on the Internet) with a crafted SPF DNS record, because of incorrect sprintf usage in SPF_record_expand_data in spf_expand.c. The vulnerable code may be part of the supply chain of a site's e-mail infrastructure (e.g., with additional configuration, Exim can use libspf2; the Postfix web site links to unofficial patches for use of libspf2 with Postfix; older versions of spfquery relied on libspf2) but most often is not.
Affected products
- Debian Linux: 9.0
- Exim libspf2: before 1.2.11 — fixed in 1.2.11
How to fix
Upgrade to a fixed version: Exim libspf2 1.2.11. Check the vendor advisory for mitigations.
References
- https://github.com/shevek/libspf2/tree/8131fe140704eaae695e76b5cd09e39bd1dd220b
- https://lists.debian.org/debian-lts-announce/2022/01/msg00015.html
- https://nathanielbennett.com/blog/libspf2-cve-jan-2022-disclosure
- https://security.gentoo.org/glsa/202401-22
- https://github.com/shevek/libspf2/tree/8131fe140704eaae695e76b5cd09e39bd1dd220b
- https://lists.debian.org/debian-lts-announce/2022/01/msg00015.html
- https://nathanielbennett.com/blog/libspf2-cve-jan-2022-disclosure
- https://security.gentoo.org/glsa/202401-22
Get alerted when CVE-2021-33912 or the next vulnerability affects your stack