What’s Vulnerable › Vulnerabilities

CVE-2021-3396

Description

OpenNMS Meridian 2016, 2017, 2018 before 2018.1.25, 2019 before 2019.1.16, and 2020 before 2020.1.5, Horizon 1.2 through 27.0.4, and Newts <1.5.3 has Incorrect Access Control, which allows local and remote code execution using JEXL expressions.

Affected products

How to fix

Upgrade to a fixed version: The OpenNMS Group Meridian 2018.1.25, 2019.1.16, 2020.1.5; OpenNMS Newts 1.5.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-3396 or the next vulnerability affects your stack