What’s Vulnerable › Vulnerabilities
CVE-2021-34085
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-11 · updated 2026-06-17
- Weakness: CWE-125
Description
Read access violation in the III_dequantize_sample function in mpglibDBL/layer3.c in mp3gain through 1.5.2-r2 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact, a different vulnerability than CVE-2017-9872. CVE-2017-14409, and CVE-2018-10778.
Affected products
- Glensawyer Mp3Gain: before 1.5.2; 1.5.2, 1.5.2-r1, 1.5.2-r2 — fixed in 1.5.2
How to fix
Upgrade to a fixed version: Glensawyer Mp3Gain 1.5.2. Check the vendor advisory for mitigations.
References
- https://drive.google.com/drive/folders/1epm65c4_iC0zE5V_leoet4Jyk1Prz2p5?usp=sharing
- https://drive.google.com/drive/folders/1epm65c4_iC0zE5V_leoet4Jyk1Prz2p5?usp=sharing
Get alerted when CVE-2021-34085 or the next vulnerability affects your stack