What’s Vulnerable › Vulnerabilities
CVE-2021-3428
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-04 · updated 2026-06-17
- Weakness: CWE-190
Description
A flaw was found in the Linux kernel. A denial of service problem is identified if an extent tree is corrupted in a crafted ext4 filesystem in fs/ext4/extents.c in ext4_es_cache_extent. Fabricating an integer overflow, A local attacker with a special user privilege may cause a system crash problem which can lead to an availability threat.
Affected products
- Linux kernel: before 5.9.0 — fixed in 5.9.0
How to fix
Upgrade to a fixed version: Linux kernel 5.9.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1972621
- https://ubuntu.com/security/CVE-2021-3428
- https://www.openwall.com/lists/oss-security/2021/03/17/1
- https://bugzilla.redhat.com/show_bug.cgi?id=1972621
- https://ubuntu.com/security/CVE-2021-3428
- https://www.openwall.com/lists/oss-security/2021/03/17/1
Get alerted when CVE-2021-3428 or the next vulnerability affects your stack