What’s Vulnerable › Vulnerabilities
CVE-2021-34337
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-15 · updated 2026-06-17
- Weakness: CWE-208
Description
An issue was discovered in Mailman Core before 3.3.5. An attacker with access to the REST API could use timing attacks to determine the value of the configured REST API password and then make arbitrary REST API calls. The REST API is bound to localhost by default, limiting the ability for attackers to exploit this, but can optionally be made to listen on other interfaces.
Affected products
- GNU Mailman: before 3.3.5 — fixed in 3.3.5
How to fix
Upgrade to a fixed version: GNU Mailman 3.3.5. Check the vendor advisory for mitigations.
References
- https://gitlab.com/mailman/mailman/-/commit/e4a39488c4510fcad8851217f10e7337a196bb51
- https://gitlab.com/mailman/mailman/-/issues/911
- https://gitlab.com/mailman/mailman/-/tags
- https://gitlab.com/mailman/mailman/-/commit/e4a39488c4510fcad8851217f10e7337a196bb51
- https://gitlab.com/mailman/mailman/-/issues/911
- https://gitlab.com/mailman/mailman/-/tags
Get alerted when CVE-2021-34337 or the next vulnerability affects your stack