What’s Vulnerable › Vulnerabilities
CVE-2021-3434: L2CAP: Stack based buffer overflow in le_ecred_conn_req()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-28 · updated 2026-06-17
- Weakness: CWE-121
Description
Stack based buffer overflow in le_ecred_conn_req(). Zephyr versions >= v2.5.0 Stack-based Buffer Overflow (CWE-121). For more information, see https://github.com/zephyrproject-rtos/zephyr/security/advisories/GHSA-8w87-6rfp-cfrm
Affected products
- zephyrproject zephyr: from 2.5.0 before 2.6.0 — fixed in 2.6.0
How to fix
Upgrade to a fixed version: zephyrproject zephyr 2.6.0. Check the vendor advisory for mitigations.
References
- http://github.com/zephyrproject-rtos/zephyr/security/advisories/GHSA-8w87-6rfp-cfrm
- http://github.com/zephyrproject-rtos/zephyr/security/advisories/GHSA-8w87-6rfp-cfrm
Get alerted when CVE-2021-3434 or the next vulnerability affects your stack