What’s Vulnerable › Vulnerabilities
CVE-2021-34349: Command Injection Vulnerability in QVR
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-27 · updated 2026-06-17
- Weakness: CWE-78
Description
A command injection vulnerability has been reported to affect QNAP device running QVR. If exploited, this vulnerability could allow remote attackers to run arbitrary commands. We have already fixed this vulnerability in the following versions of QVR: QVR 5.1.5 build 20210803 and later
Affected products
- QNAP Systems Inc. QVR: before 5.1.5 — fixed in 5.1.5
How to fix
Upgrade to a fixed version: QNAP Systems Inc. QVR 5.1.5. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-21-35
- https://www.qnap.com/en/security-advisory/qsa-21-35
Get alerted when CVE-2021-34349 or the next vulnerability affects your stack