What’s Vulnerable › Vulnerabilities
CVE-2021-3435: L2CAP: Information leakage in le_ecred_conn_req()
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-28 · updated 2026-06-17
- Weakness: CWE-908
Description
Information leakage in le_ecred_conn_req(). Zephyr versions >= v2.4.0 Use of Uninitialized Resource (CWE-908). For more information, see https://github.com/zephyrproject-rtos/zephyr/security/advisories/GHSA-xhg3-gvj6-4rqh
Affected products
- zephyrproject zephyr: from 2.4.0 before 2.6.0 — fixed in 2.6.0
How to fix
Upgrade to a fixed version: zephyrproject zephyr 2.6.0. Check the vendor advisory for mitigations.
References
- http://github.com/zephyrproject-rtos/zephyr/security/advisories/GHSA-xhg3-gvj6-4rqh
- http://github.com/zephyrproject-rtos/zephyr/security/advisories/GHSA-xhg3-gvj6-4rqh
Get alerted when CVE-2021-3435 or the next vulnerability affects your stack