What’s Vulnerable › Vulnerabilities
CVE-2021-34357: Reflected XSS Vulnerability in QmailAgent
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-13 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability has been reported to affect QNAP device running QmailAgent. If exploited, this vulnerability allows remote attackers to inject malicious code. We have already fixed this vulnerability in the following versions of QmailAgent: QmailAgent 3.0.2 ( 2021/08/25 ) and later
Affected products
- QNAP Systems Inc. QmailAgent: before 3.0.2 — fixed in 3.0.2
How to fix
Upgrade to a fixed version: QNAP Systems Inc. QmailAgent 3.0.2. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-21-47
- https://www.qnap.com/en/security-advisory/qsa-21-47
Get alerted when CVE-2021-34357 or the next vulnerability affects your stack