What’s Vulnerable › Vulnerabilities
CVE-2021-34359: Stored XSS Vulnerability in Proxy Server
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-25 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability has been reported to affect QNAP device running Proxy Server. If exploited, this vulnerability allows remote attackers to inject malicious code. We have already fixed this vulnerability in the following versions of Proxy Server: QTS 4.5.x: Proxy Server 1.4.2 ( 2021/12/30 ) and later
Affected products
- QNAP Systems Inc. Proxy Server: before 1.4.2 — fixed in 1.4.2
How to fix
Upgrade to a fixed version: QNAP Systems Inc. Proxy Server 1.4.2. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-22-04
- https://www.qnap.com/en/security-advisory/qsa-22-04
Get alerted when CVE-2021-34359 or the next vulnerability affects your stack