What’s Vulnerable › Vulnerabilities
CVE-2021-34448: Microsoft Windows Scripting Engine Memory Corruption Vulnerability
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: yes — in CISA KEV since 2021-11-03
- EPSS: 40.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-16 · updated 2026-08-10
- Weakness: CWE-787
Description
Scripting Engine Memory Corruption Vulnerability
Affected products
- Microsoft Windows 10 Version 1507: before 10.0.10240.19003 — fixed in 10.0.10240.19003
- Microsoft Windows 10 1607: before 10.0.14393.4530 — fixed in 10.0.14393.4530
- Microsoft Windows 10: before 10.0.17763.2061 — fixed in 10.0.17763.2061
- Microsoft Windows 10 1909: before 10.0.18363.1679 — fixed in 10.0.18363.1679
- Microsoft Windows 10 2004: before 10.0.19041.1110 — fixed in 10.0.19041.1110
- Microsoft Windows 10 20H2: before 10.0.19042.1110 — fixed in 10.0.19042.1110
- Microsoft Windows 10 21H1: before 10.0.19043.1110 — fixed in 10.0.19043.1110
- Microsoft Windows 7: all versions
- Microsoft Windows 8.1: all versions
- Microsoft Windows RT 8.1: all versions
- Microsoft Windows Server 2008: r2-sp1
- Microsoft Windows Server 2012: r2
- Microsoft Windows Server 2016: before 10.0.14393.4530 — fixed in 10.0.14393.4530
- Microsoft Windows Server 2019: before 10.0.17763.2061 — fixed in 10.0.17763.2061
How to fix
Upgrade to a fixed version: Microsoft Windows 10 Version 1507 10.0.10240.19003; Microsoft Windows 10 1607 10.0.14393.4530; Microsoft Windows 10 10.0.17763.2061; Microsoft Windows 10 1909 10.0.18363.1679; Microsoft Windows 10 2004 10.0.19041.1110; Microsoft Windows 10 20H2 10.0.19042.1110; Microsoft Windows 10 21H1 10.0.19043.1110; Microsoft Windows Server 2016 10.0.14393.4530; Microsoft Windows Server 2019 10.0.17763.2061. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2021-34448
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2021-34448
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2021-34448
Get alerted when CVE-2021-34448 or the next vulnerability affects your stack