What’s Vulnerable › Vulnerabilities
CVE-2021-3449: NULL pointer deref in signature_algorithms processing
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 63.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-25 · updated 2026-10-08
- Weakness: CWE-476
Description
An OpenSSL TLS server may crash if sent a maliciously crafted renegotiation ClientHello message from a client. If a TLSv1.2 renegotiation ClientHello omits the signature_algorithms extension (where it was present in the initial ClientHello), but includes a signature_algorithms_cert extension then a NULL pointer dereference will result, leading to a crash and a denial of service attack. A server is only vulnerable if it has TLSv1.2 and renegotiation enabled (which is the default configuration). OpenSSL TLS clients are not impacted by this issue. All OpenSSL 1.1.1 versions are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1k. OpenSSL 1.0.2 is not impacted by this issue. Fixed in OpenSSL 1.1.1k (Affected 1.1.1-1.1.1j).
Affected products
- checkpoint Multi-Domain Management Firmware: r80.40, r81
- Check Point Quantum Security Gateway: r80.40, r81
- checkpoint Quantum Security Management Firmware: r80.40, r81
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 34
- FreeBSD: 12.2, 12.2-p1, 12.2-p2
- McAfee Web Gateway (MWG): 8.2.19, 9.2.10, 10.1.1
- McAfee Web Gateway Cloud Service: 8.2.19, 9.2.10, 10.1.1
- Active IQ Unified Manager for VMware vSphere, Linux, and Microsoft Windows: all versions
- NetApp Cloud Volumes Ontap Mediator: all versions
- NetApp E-Series Performance Analyzer: all versions
- OnCommand Insight: all versions
- NetApp OnCommand Workflow Automation: all versions
- NetApp ONTAP Select Deploy administration utility: all versions
- NetApp Santricity Smi-S Provider: all versions
- NetApp SnapCenter: all versions
- NetApp StorageGRID: all versions
- Node.js: from 10.0.0 through 10.12.0; from 10.13.0 through 10.24.0; from 12.0.0 through 12.12.0; from 12.13.0 before 12.22.1; from 14.0.0 through 14.14.0; from 14.15.0 before 14.16.1 — fixed in 12.22.1, 14.16.1, 15.14.0
- OpenSSL: from 1.1.1 before 1.1.1k — fixed in 1.1.1k
- Oracle Communications Communications Policy Management: 12.6.0.0.0
- Oracle Enterprise Manager For Storage Management: 13.4.0.0
- Oracle Corporation Oracle Essbase: 21.2
- Oracle Corporation GraalVM Enterprise Edition: 19.3.5, 20.3.1.2, 21.0.0.2
- Oracle Corporation JD Edwards EnterpriseOne Tools: before 9.2.6.0 — fixed in 9.2.6.0
- Oracle Jd Edwards World Security: a9.4
- Oracle Mysql Connectors: through 8.0.23
- MySQL Server: through 5.7.33; from 8.0.15 through 8.0.23
- Oracle Corporation MySQL Workbench: through 8.0.23
- Oracle Corporation PeopleSoft Enterprise PT PeopleTools: 8.57, 8.58, 8.59
- Oracle Corporation Primavera Unifier: from 17.7 through 17.12; 19.12, 20.12, 21.12
How to fix
Upgrade to a fixed version: Node.js 12.22.1, 14.16.1, 15.14.0; OpenSSL 1.1.1k; Oracle Corporation JD Edwards EnterpriseOne Tools 9.2.6.0; Oracle Corporation Oracle Secure Backup 18.1.0.1.0; Siemens Scalance Xb-200 Firmware 4.3; Siemens Scalance Xc-200 Firmware 4.3; Siemens Scalance Xf-200Ba Firmware 4.3; Siemens Scalance Xm-400 Firmware 6.4; Siemens Scalance Xp-200 Firmware 4.3; Siemens Scalance Xr-300Wg Firmware 4.3; Siemens Scalance Xr524-8C Firmware 6.4; Siemens Scalance Xr526-8C Firmware 6.4. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2021/03/27/1
- http://www.openwall.com/lists/oss-security/2021/03/27/2
- http://www.openwall.com/lists/oss-security/2021/03/28/3
- http://www.openwall.com/lists/oss-security/2021/03/28/4
- https://cert-portal.siemens.com/productcert/pdf/ssa-389290.pdf
- https://cert-portal.siemens.com/productcert/pdf/ssa-772220.pdf
- https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=fb9fa6b51defd48157eeb207f52181f735d96148
- https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA44845
- https://kc.mcafee.com/corporate/index?page=content&id=SB10356
- https://lists.debian.org/debian-lts-announce/2021/08/msg00029.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CCBFLLVQVILIVGZMBJL3IXZGKWQISYNP/
- https://psirt.global.sonicwall.com/vuln-detail/SNWLID-2021-0013
Get alerted when CVE-2021-3449 or the next vulnerability affects your stack