What’s Vulnerable › Vulnerabilities
CVE-2021-34527: Windows Print Spooler Remote Code Execution Vulnerability
- Severity: critical (CVSS 9.0 v2.0)
- Exploited in the wild: yes — in CISA KEV since 2021-11-03
- EPSS: 99.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-07-02 · updated 2026-08-10
Description
A remote code execution vulnerability exists when the Windows Print Spooler service improperly performs privileged file operations. An attacker who successfully exploited this vulnerability could run arbitrary code with SYSTEM privileges. An attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. UPDATE July 7, 2021: The security update for Windows Server 2012, Windows Server 2016 and Windows 10, Version 1607 have been released. Please see the Security Updates table for the applicable update for your system. We recommend that you install these updates immediately. If you are unable to install these updates, see the FAQ and Workaround sections in this CVE for information on how to help protect your system from this vulnerability. In addition to installing the updates, in order to secure your system, you must confirm that the following registry settings are set to 0 (zero) or are not defined (Note: These registry keys do not exist by default, and therefore are already at the secure setting.), also that your Group Policy setting are correct (see FAQ): HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Printers\PointAndPrint NoWarningNoElevationOnInstall = 0 (DWORD) or not defined (default setting) UpdatePromptSettings = 0 (DWORD) or not defined (default setting) Having NoWarningNoElevationOnInstall set to 1 makes your system vulnerable by design. UPDATE July 6, 2021: Microsoft has completed the investigation and has released security updates to address this vulnerability. Please see the Security Updates table for the applicable update for your system. We recommend that you install these updates immediately. If you are unable to install these updates, see the FAQ and Workaround sections in this CVE for information on how to help protect your system from this vulnerability. See also KB5005010: Restricting installation of new printer drivers after applying the July 6, 2021 updates. Note that the security updates released on and after July 6, 2021 contain protections for CVE-2021-1675 and the additional remote code execution exploit in the Windows Print Spooler service known as “PrintNightmare”, documented in CVE-2021-34527.
Affected products
- Microsoft Windows 10 Version 1507: before 10.0.10240.18969 — fixed in 10.0.10240.18969
- Microsoft Windows 10 1607: before 10.0.14393.4470 — fixed in 10.0.14393.4470
- Microsoft Windows 10: before 10.0.17763.2029 — fixed in 10.0.17763.2029
- Microsoft Windows 10 20H2: before 10.0.19042.1083 — fixed in 10.0.19042.1083
- Microsoft Windows 10: before 10.0.19044.1415 — fixed in 10.0.19044.1415
- Microsoft Windows 10: before 10.0.19045.2251 — fixed in 10.0.19045.2251
- Microsoft Windows 11 21H2: before 10.0.22000.318 — fixed in 10.0.22000.318
- Microsoft Windows 11: before 10.0.22621.674 — fixed in 10.0.22621.674
- Microsoft Windows RT 8.1: all versions
- Microsoft Windows Server 2008: r2-sp1
- Microsoft Windows Server 2012: r2
- Microsoft Windows Server 2016: before 10.0.14393.4470 — fixed in 10.0.14393.4470
- Microsoft Windows Server 2019: before 10.0.17763.2029 — fixed in 10.0.17763.2029
- Microsoft Windows Server 2022: before 10.0.20348.230 — fixed in 10.0.20348.230
- Microsoft Windows Server 20H2: before 10.0.19042.1083 — fixed in 10.0.19042.1083
- Microsoft Windows 10 Version 1507: from 10.0.10240.0 before 10.0.10240.18969 — fixed in 10.0.10240.18969
- Microsoft Windows 10 1607: from 10.0.14393.0 before 10.0.14393.4470 — fixed in 10.0.14393.4470
- Microsoft Windows 10: from 10.0.17763.0 before 10.0.17763.2029 — fixed in 10.0.17763.2029
- Microsoft Windows 10 20H2: from 10.0.0 before 10.0.19042.1083 — fixed in 10.0.19042.1083
- Microsoft Windows 10: from 10.0.19044.0 before 10.0.19044.1415 — fixed in 10.0.19044.1415
- Microsoft Windows 10: from 10.0.19045.0 before 10.0.19045.2251 — fixed in 10.0.19045.2251
- Microsoft Windows 11 21H2: from 10.0.22000.0 before 10.0.22000.318 — fixed in 10.0.22000.318
- Microsoft Windows 11: from 10.0.22621.0 before 10.0.22621.674 — fixed in 10.0.22621.674
- Microsoft Windows 8.1: from 6.3.0 before 6.3.9600.20046 — fixed in 6.3.9600.20046
- Microsoft Windows Server 2008 R2 Service Pack 1: from 6.1.7601.0 before 6.1.7601.25633 — fixed in 6.1.7601.25633
- Microsoft Windows Server 2008 Service Pack 2: from 6.0.6003.0 before 6.0.6003.21138 — fixed in 6.0.6003.21138
- Microsoft Windows Server 2012: from 6.2.9200.0 before 6.2.9200.23383 — fixed in 6.2.9200.23383
- Microsoft Windows Server 2012 R2: from 6.3.9600.0 before 6.3.9600.20046 — fixed in 6.3.9600.20046
- Microsoft Windows Server 2016: from 10.0.14393.0 before 10.0.14393.4470 — fixed in 10.0.14393.4470
- Microsoft Windows Server 2019: from 10.0.17763.0 before 10.0.17763.2029 — fixed in 10.0.17763.2029
How to fix
Upgrade to a fixed version: Microsoft Windows 10 Version 1507 10.0.10240.18969; Microsoft Windows 10 1607 10.0.14393.4470; Microsoft Windows 10 10.0.17763.2029; Microsoft Windows 10 20H2 10.0.19042.1083; Microsoft Windows 10 10.0.19044.1415; Microsoft Windows 10 10.0.19045.2251; Microsoft Windows 11 21H2 10.0.22000.318; Microsoft Windows 11 10.0.22621.674; Microsoft Windows Server 2016 10.0.14393.4470; Microsoft Windows Server 2019 10.0.17763.2029; Microsoft Windows Server 2022 10.0.20348.230; Microsoft Windows Server 20H2 10.0.19042.1083. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2021-34527
- http://packetstormsecurity.com/files/167261/Print-Spooler-Remote-DLL-Injection.html
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2021-34527
- https://www.kb.cert.org/vuls/id/383432
- https://www.vicarius.io/vsociety/posts/cve-2021-34527-printnightmare-detection-script
- https://www.vicarius.io/vsociety/posts/cve-2021-34527-printnightmare-mitigation-script
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2021-34527
Get alerted when CVE-2021-34527 or the next vulnerability affects your stack