What’s Vulnerable › Vulnerabilities
CVE-2021-34539
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-10 · updated 2026-06-17
- Weakness: CWE-668
Description
An issue was discovered in CubeCoders AMP before 2.1.1.8. A lack of validation of the Java Version setting means that an unintended executable path can be set. The result is that high-privileged users can trigger code execution.
Affected products
- Cubecoders Amp: before 2.1.1.8 — fixed in 2.1.1.8
How to fix
Upgrade to a fixed version: Cubecoders Amp 2.1.1.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-34539 or the next vulnerability affects your stack