What’s Vulnerable › Vulnerabilities
CVE-2021-34551
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-16 · updated 2026-06-17
- Weakness: CWE-434
Description
PHPMailer before 6.5.0 on Windows allows remote code execution if lang_path is untrusted data and has a UNC pathname.
Affected products
- Fedoraproject Fedora: 33, 34
- Phpmailer Project Phpmailer: before 6.5.0 — fixed in 6.5.0
How to fix
Upgrade to a fixed version: Phpmailer Project Phpmailer 6.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/PHPMailer/PHPMailer/blob/master/SECURITY.md
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3YRMWGA4VTMXFB22KICMB7YMFZNFV3EJ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FJYSOFCUBS67J3TKR74SD3C454N7VTYM/
- https://github.com/PHPMailer/PHPMailer/blob/master/SECURITY.md
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3YRMWGA4VTMXFB22KICMB7YMFZNFV3EJ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FJYSOFCUBS67J3TKR74SD3C454N7VTYM/
Get alerted when CVE-2021-34551 or the next vulnerability affects your stack