What’s Vulnerable › Vulnerabilities

CVE-2021-34552: Buffer Overflow in Pillow

Description

Pillow through 8.2.0 and PIL (aka Python Imaging Library) through 1.1.7 allow an attacker to pass controlled parameters directly into a convert function to trigger a buffer overflow in Convert.c.

Affected products

How to fix

Upgrade to a fixed version: Pypi Pillow 8.3.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-34552 or the next vulnerability affects your stack