What’s Vulnerable › Vulnerabilities
CVE-2021-34599: Improper Certificate Validation in CODESYS Git
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-01 · updated 2026-06-17
- Weakness: CWE-295
Description
Affected versions of CODESYS Git in Versions prior to V1.1.0.0 lack certificate validation in HTTPS handshakes. CODESYS Git does not implement certificate validation by default, so it does not verify that the server provides a valid and trusted HTTPS certificate. Since the certificate of the server to which the connection is made is not properly verified, the server connection is vulnerable to a man-in-the-middle attack.
Affected products
- CODESYS Git: before 1.1.0.0 — fixed in 1.1.0.0
How to fix
Upgrade to a fixed version: CODESYS Git 1.1.0.0. Check the vendor advisory for mitigations.
References
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=16959&token=3ce11e44a3277c4520d732ea2e630f2e06bd46ff&download
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=16959&token=3ce11e44a3277c4520d732ea2e630f2e06bd46ff&download
Get alerted when CVE-2021-34599 or the next vulnerability affects your stack