What’s Vulnerable › Vulnerabilities
CVE-2021-34630: Reflected XSS in GTranslate Pro and GTranslate Enterprise < 2.8.65
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-07-30 · updated 2026-06-17
- Weakness: CWE-116
Description
In the Pro and Enterprise versions of GTranslate < 2.8.65, the gtranslate_request_uri_var function runs at the top of all pages and echoes out the contents of $_SERVER['REQUEST_URI']. Although this uses addslashes, and most modern browsers automatically URLencode requests, this plugin is still vulnerable to Reflected XSS in older browsers such as Internet Explorer 9 or below, or in cases where an attacker is able to modify the request en route between the client and the server, or in cases where the user is using an atypical browsing solution.
Affected products
- Drupal Translate Drupal with GTranslate: before 2.8.65 — fixed in 2.8.65
How to fix
Upgrade to a fixed version: Drupal Translate Drupal with GTranslate 2.8.65. Check the vendor advisory for mitigations.
References
- https://plugins.svn.wordpress.org/gtranslate/tags/2.8.64/gtranslate.php
- https://plugins.svn.wordpress.org/gtranslate/tags/2.8.64/gtranslate.php
Get alerted when CVE-2021-34630 or the next vulnerability affects your stack