What’s Vulnerable › Vulnerabilities

CVE-2021-34641: SEOPress <= 5.0.0 – 5.0.3 Authenticated Stored Cross-Site Scripting

Description

The SEOPress WordPress plugin is vulnerable to Stored Cross-Site-Scripting via the processPut function found in the ~/src/Actions/Api/TitleDescriptionMeta.php file which allows authenticated attackers to inject arbitrary web scripts, in versions 5.0.0 - 5.0.3.

Affected products

How to fix

Upgrade to a fixed version: SEOPress 5.0.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-34641 or the next vulnerability affects your stack