What’s Vulnerable › Vulnerabilities
CVE-2021-3469
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-03 · updated 2026-06-17
- Weakness: CWE-863
Description
Foreman versions before 2.3.4 and before 2.4.0 is affected by an improper authorization handling flaw. An authenticated attacker can impersonate the foreman-proxy if product enable the Puppet Certificate authority (CA) to sign certificate requests that have subject alternative names (SANs). Foreman do not enable SANs by default and `allow-authorization-extensions` is set to `false` unless user change `/etc/puppetlabs/puppetserver/conf.d/ca.conf` configuration explicitly.
Affected products
- foreman: before 2.3.4 — fixed in 2.3.4
How to fix
Upgrade to a fixed version: foreman 2.3.4. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1943630
- https://bugzilla.redhat.com/show_bug.cgi?id=1943630
Get alerted when CVE-2021-3469 or the next vulnerability affects your stack