What’s Vulnerable › Vulnerabilities

CVE-2021-3470

Description

A heap overflow issue was found in Redis in versions before 5.0.10, before 6.0.9 and before 6.2.0 when using a heap allocator other than jemalloc or glibc's malloc, leading to potential out of bound write or process crash. Effectively this flaw does not affect the vast majority of users, who use jemalloc or glibc malloc.

Affected products

How to fix

Upgrade to a fixed version: Redis Labs Redis 5.0.10, 6.0.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-3470 or the next vulnerability affects your stack