What’s Vulnerable › Vulnerabilities
CVE-2021-34704: Cisco Adaptive Security Appliance Software and Firepower Threat Defense Software Web Services Denial of Service Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-11 · updated 2026-08-11
- Weakness: CWE-121
Description
A vulnerability in the web services interface of Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to trigger a denial of service (DoS) condition. This vulnerability is due to improper input validation when parsing HTTPS requests. An attacker could exploit this vulnerability by sending a malicious HTTPS request to an affected device. A successful exploit could allow the attacker to cause the device to reload, resulting in a DoS condition.
Affected products
- Cisco ASA Software: from 9.15 before 9.15.1.17; from 9.16 before 9.16.2 — fixed in 9.15.1.17, 9.16.2
- Cisco Firepower Threat Defense Software: from 6.7.0 before 6.7.0.3; 7.0.0 — fixed in 6.7.0.3
How to fix
Upgrade to a fixed version: Cisco ASA Software 9.15.1.17, 9.16.2; Cisco Firepower Threat Defense Software 6.7.0.3. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asafdt-webvpn-dos-KSqJAKPA
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asafdt-webvpn-dos-KSqJAKPA
Get alerted when CVE-2021-34704 or the next vulnerability affects your stack