What’s Vulnerable › Vulnerabilities
CVE-2021-34716: Cisco Expressway Series and TelePresence Video Communication Server Remote Code Execution Vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-18 · updated 2026-06-17
- Weakness: CWE-460
Description
A vulnerability in the web-based management interface of Cisco Expressway Series and Cisco TelePresence Video Communication Server (VCS) could allow an authenticated, remote attacker to execute arbitrary code on the underlying operating system as the root user. This vulnerability is due to incorrect handling of certain crafted software images that are uploaded to the affected device. An attacker could exploit this vulnerability by authenticating to the system as an administrative user and then uploading specific crafted software images to the affected device. A successful exploit could allow the attacker to execute arbitrary code on the underlying operating system as the root user.
Affected products
- Cisco Expressway: from x8.6.0 before x14.1 — fixed in x14.1
- Cisco TelePresence Video Communication Server (VCS) Expressway: from x8.6 through x14.0.3
How to fix
Upgrade to a fixed version: Cisco Expressway x14.1. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ewrce-QPynNCjh
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ewrce-QPynNCjh
Get alerted when CVE-2021-34716 or the next vulnerability affects your stack