What’s Vulnerable › Vulnerabilities
CVE-2021-3475
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-30 · updated 2026-06-17
- Weakness: CWE-190
Description
There is a flaw in OpenEXR in versions before 3.0.0-beta. An attacker who can submit a crafted file to be processed by OpenEXR could cause an integer overflow, potentially leading to problems with application availability.
Affected products
- Debian Linux: 9.0, 10.0
- AcademySoftwareFoundation openexr: before 2.4.3; from 2.5.0 before 2.5.4 — fixed in 2.4.3, 2.5.4
How to fix
Upgrade to a fixed version: AcademySoftwareFoundation openexr 2.4.3, 2.5.4. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=25297
- https://bugzilla.redhat.com/show_bug.cgi?id=1939144
- https://lists.debian.org/debian-lts-announce/2021/07/msg00001.html
- https://lists.debian.org/debian-lts-announce/2022/12/msg00022.html
- https://security.gentoo.org/glsa/202107-27
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=25297
- https://bugzilla.redhat.com/show_bug.cgi?id=1939144
- https://lists.debian.org/debian-lts-announce/2021/07/msg00001.html
- https://lists.debian.org/debian-lts-announce/2022/12/msg00022.html
- https://security.gentoo.org/glsa/202107-27
Get alerted when CVE-2021-3475 or the next vulnerability affects your stack