What’s Vulnerable › Vulnerabilities
CVE-2021-34752: Cisco Firepower Threat Defense Command Injection Vulnerabilities
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-15 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability in the CLI of Cisco FTD Software could allow an authenticated, local attacker with administrative privileges to execute arbitrary commands with root privileges on the underlying operating system of an affected device. This vulnerability is due to insufficient validation of user-supplied command arguments. An attacker could exploit this vulnerability by submitting crafted input to the affected commands. A successful exploit could allow the attacker to execute commands with root privileges on the underlying operating system. Cisco has released software updates that address this vulnerability. There are no workarounds that address this vulnerability.
Affected products
- Cisco Firepower Threat Defense Software: before 6.4.0.13; from 6.5.0 before 6.6.5; from 6.7.0 before 6.7.0.3; from 7.0.0 before 7.0.1 — fixed in 6.4.0.13, 6.6.5, 6.7.0.3, 7.0.1
How to fix
Upgrade to a fixed version: Cisco Firepower Threat Defense Software 6.4.0.13, 6.6.5, 6.7.0.3, 7.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-34752 or the next vulnerability affects your stack