What’s Vulnerable › Vulnerabilities
CVE-2021-34755: Cisco Firepower Threat Defense Software Command Injection Vulnerabilities
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-27 · updated 2026-08-11
- Weakness: CWE-20
Description
Multiple vulnerabilities in the CLI of Cisco Firepower Threat Defense (FTD) Software could allow an authenticated, local attacker to execute arbitrary commands with root privileges. For more information about these vulnerabilities, see the Details section of this advisory.
Affected products
- Cisco Firepower Management Center Virtual Appliance: 6.1.0, 6.2.0, 6.2.3, 6.3.0, 6.4.0, 6.4.0.11 (+6)
- Cisco Firepower Threat Defense Software: from 6.4.0 before 6.4.0.13; from 6.6.0 before 6.6.5; from 6.7.0 before 6.7.0.3; from 7.0.0 before 7.0.1 — fixed in 6.4.0.13, 6.6.5, 6.7.0.3, 7.0.1
- Cisco Sourcefire Defense Center: 6.1.0, 6.2.0, 6.2.3, 6.3.0, 6.4.0, 6.4.0.11 (+6)
How to fix
Upgrade to a fixed version: Cisco Firepower Threat Defense Software 6.4.0.13, 6.6.5, 6.7.0.3, 7.0.1. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ftd-cmdinject-FmzsLN8
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ftd-cmdinject-FmzsLN8
Get alerted when CVE-2021-34755 or the next vulnerability affects your stack