What’s Vulnerable › Vulnerabilities
CVE-2021-34783: Cisco Adaptive Security Appliance Software and Firepower Threat Defense Software Software-Based SSL/TLS Denial of Service Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-27 · updated 2026-08-11
- Weakness: CWE-119
Description
A vulnerability in the software-based SSL/TLS message handler of Cisco Adaptive Security Appliance (ASA) Software and Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to cause an affected device to reload, resulting in a denial of service (DoS) condition. This vulnerability is due to insufficient validation of SSL/TLS messages when the device performs software-based SSL/TLS decryption. An attacker could exploit this vulnerability by sending a crafted SSL/TLS message to an affected device. A successful exploit could allow the attacker to cause the affected device to reload, resulting in a DoS condition. Note: Datagram TLS (DTLS) messages cannot be used to exploit this vulnerability.
Affected products
- Cisco ASA Software: from 9.8.0 before 9.8.4.40; from 9.12.0 before 9.12.4.29; from 9.14.0 before 9.14.3.9; from 9.15.0 before 9.15.1.17; from 9.16.0 before 9.16.2 — fixed in 9.12.4.29, 9.14.3.9, 9.15.1.17, 9.16.2, 9.8.4.40
- Cisco Asa 5505 Firmware: 009.016(001), 009.016(001.025)
- Cisco Asa 5512-X Firmware: 009.016(001), 009.016(001.025)
- Cisco Asa 5515-X Firmware: 009.016(001), 009.016(001.025)
- Cisco Asa 5525-X Firmware: 009.016(001), 009.016(001.025)
- Cisco Asa 5545-X Firmware: 009.016(001), 009.016(001.025)
- Cisco Asa 5555-X Firmware: 009.016(001), 009.016(001.025)
- Cisco Asa 5580 Firmware: 009.016(001), 009.016(001.025)
- Cisco Asa 5585-X Firmware: 009.016(001), 009.016(001.025)
- Cisco Firepower Threat Defense Software: from 6.4.0 before 6.4.0.13; from 6.6.0 before 6.6.5; from 6.7.0 before 6.7.0.3; from 7.0.0 before 7.0.1 — fixed in 6.4.0.13, 6.6.5, 6.7.0.3, 7.0.1
How to fix
Upgrade to a fixed version: Cisco ASA Software 9.12.4.29, 9.14.3.9, 9.15.1.17, 9.16.2; Cisco Firepower Threat Defense Software 6.4.0.13, 6.6.5, 6.7.0.3, 7.0.1. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ftd-tls-decrypt-dos-BMxYjm8M
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ftd-tls-decrypt-dos-BMxYjm8M
Get alerted when CVE-2021-34783 or the next vulnerability affects your stack