What’s Vulnerable › Vulnerabilities
CVE-2021-34784: Cisco Prime Infrastructure and Evolved Programmable Network Manager Stored Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-04 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in the web-based management interface of Cisco Prime Infrastructure (PI) and Cisco Evolved Programmable Network Manager (EPNM) could allow an authenticated, remote attacker to conduct a stored cross-site scripting (XSS) attack against a user of the web-based management interface of an affected device. This vulnerability exists because the web-based management interface does not properly validate user-supplied input. An attacker could exploit this vulnerability by persuading a user of an affected interface to click a crafted link. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or access sensitive, browser-based information.
Affected products
- Cisco Evolved Programmable Network Manager (EPNM): before 5.1.2 — fixed in 5.1.2
- Cisco Prime Infrastructure: before 3.10 — fixed in 3.10
How to fix
Upgrade to a fixed version: Cisco Evolved Programmable Network Manager (EPNM) 5.1.2; Cisco Prime Infrastructure 3.10. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-pi-epnm-xss-U2JK537j
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-pi-epnm-xss-U2JK537j
Get alerted when CVE-2021-34784 or the next vulnerability affects your stack