What’s Vulnerable › Vulnerabilities
CVE-2021-34787: Cisco Adaptive Security Appliance Software and Firepower Threat Defense Software Identity-Based Rule Bypass Vulnerability
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-27 · updated 2026-08-11
- Weakness: CWE-183
Description
A vulnerability in the identity-based firewall (IDFW) rule processing feature of Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to bypass security protections. This vulnerability is due to improper handling of network requests by affected devices configured to use object group search. An attacker could exploit this vulnerability by sending a specially crafted network request to an affected device. A successful exploit could allow the attacker to bypass access control list (ACL) rules on the device, bypass security protections, and send network traffic to unauthorized hosts.
Affected products
- Cisco Adaptive Security Appliance: before 9.8.4.40 — fixed in 9.8.4.40
- Cisco ASA Software: from 9.9.0 before 9.12.4.25; from 9.13.0 before 9.14.3.1; from 9.15.0 before 9.15.1.17; from 9.16.0 before 9.16.1.28 — fixed in 9.12.4.25, 9.14.3.1, 9.15.1.17, 9.16.1.28
- Cisco Asa 5505 Firmware: 009.009, 009.012
- Cisco Asa 5512-X Firmware: 009.009, 009.012
- Cisco Asa 5515-X Firmware: 009.009, 009.012
- Cisco Asa 5525-X Firmware: 009.009, 009.012
- Cisco Asa 5545-X Firmware: 009.009, 009.012
- Cisco Asa 5555-X Firmware: 009.009, 009.012
- Cisco Asa 5580 Firmware: 009.009, 009.012
- Cisco Asa 5585-X Firmware: 009.009, 009.012
- Cisco Firepower Threat Defense Software: before 6.4.0.13; from 6.5.0 before 6.6.5; from 6.7.0 before 6.7.0.3; from 7.0.0 before 7.0.1 — fixed in 6.4.0.13, 6.6.5, 6.7.0.3, 7.0.1
How to fix
Upgrade to a fixed version: Cisco Adaptive Security Appliance 9.8.4.40; Cisco ASA Software 9.12.4.25, 9.14.3.1, 9.15.1.17, 9.16.1.28; Cisco Firepower Threat Defense Software 6.4.0.13, 6.6.5, 6.7.0.3, 7.0.1. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asaftd-rule-bypass-ejjOgQEY
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asaftd-rule-bypass-ejjOgQEY
Get alerted when CVE-2021-34787 or the next vulnerability affects your stack