What’s Vulnerable › Vulnerabilities
CVE-2021-34790: Cisco Adaptive Security Appliance Software and Firepower Threat Defense Software Application Level Gateway Bypass Vulnerabilities
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-27 · updated 2026-08-11
- Weakness: CWE-358
Description
Multiple vulnerabilities in the Application Level Gateway (ALG) for the Network Address Translation (NAT) feature of Cisco Adaptive Security Appliance (ASA) Software and Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to bypass the ALG and open unauthorized connections with a host located behind the ALG. For more information about these vulnerabilities, see the Details section of this advisory. Note: These vulnerabilities have been publicly discussed as NAT Slipstreaming.
Affected products
- Cisco Adaptive Security Appliance: before 9.8.4.40 — fixed in 9.8.4.40
- Cisco ASA Software: from 9.12.0 before 9.12.4.29; from 9.13.0 before 9.14.2.15; from 9.15.0 before 9.15.1.15 — fixed in 9.12.4.29, 9.14.2.15, 9.15.1.15
- Cisco Asa 5505 Firmware: 009.008, 009.015
- Cisco Asa 5512-X Firmware: 009.008, 009.015
- Cisco Asa 5515-X Firmware: 009.008, 009.015
- Cisco Asa 5525-X Firmware: 009.008, 009.015
- Cisco Asa 5545-X Firmware: 009.008, 009.015
- Cisco Asa 5555-X Firmware: 009.008, 009.015
- Cisco Asa 5580 Firmware: 009.008, 009.015
- Cisco Asa 5585-X Firmware: 009.008, 009.015
- Cisco Firepower Threat Defense Software: before 6.4.0.12; from 6.5.0 before 6.6.5; from 6.7.0 before 6.7.0.2 — fixed in 6.4.0.12, 6.6.5, 6.7.0.2
How to fix
Upgrade to a fixed version: Cisco Adaptive Security Appliance 9.8.4.40; Cisco ASA Software 9.12.4.29, 9.14.2.15, 9.15.1.15; Cisco Firepower Threat Defense Software 6.4.0.12, 6.6.5, 6.7.0.2. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-natalg-bypass-cpKGqkng
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-natalg-bypass-cpKGqkng
Get alerted when CVE-2021-34790 or the next vulnerability affects your stack