What’s Vulnerable › Vulnerabilities
CVE-2021-34815
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-18 · updated 2026-06-17
- Weakness: CWE-79
Description
CheckSec Canopy before 3.5.2 allows XSS attacks against the login page via the LOGIN_PAGE_DISCLAIMER parameter.
Affected products
- Checksec Canopy: before 3.5.2 — fixed in 3.5.2
How to fix
Upgrade to a fixed version: Checksec Canopy 3.5.2. Check the vendor advisory for mitigations.
References
- https://www.checksec.com/canopy.html
- https://www.compass-security.com/en/research/advisories
- https://www.compass-security.com/fileadmin/Research/Advisories/2021-10_CSNC-2021-015-Checksec_Canopy_HTLM_Injection.txt
- https://www.checksec.com/canopy.html
- https://www.compass-security.com/en/research/advisories
- https://www.compass-security.com/fileadmin/Research/Advisories/2021-10_CSNC-2021-015-Checksec_Canopy_HTLM_Injection.txt
Get alerted when CVE-2021-34815 or the next vulnerability affects your stack