What’s Vulnerable › Vulnerabilities
CVE-2021-3485: Improper Input Validation in Bitdefender Endpoint Security Tools for Linux
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-24 · updated 2026-06-17
- Weakness: CWE-494
Description
An Improper Input Validation vulnerability in the Product Update feature of Bitdefender Endpoint Security Tools for Linux allows a man-in-the-middle attacker to abuse the DownloadFile function of the Product Update to achieve remote code execution. This issue affects: Bitdefender Endpoint Security Tools for Linux versions prior to 6.2.21.155.
Affected products
- Bitdefender Endpoint Security Tools: before 6.2.21.155 — fixed in 6.2.21.155
How to fix
Upgrade to a fixed version: Bitdefender Endpoint Security Tools 6.2.21.155. Check the vendor advisory for mitigations.
References
- https://herolab.usd.de/security-advisories/usd-2021-0014/
- https://www.bitdefender.com/support/security-advisories/improper-input-validation-in-bitdefender-endpoint-security-tools-for-linux-va-9769
- https://herolab.usd.de/security-advisories/usd-2021-0014/
- https://www.bitdefender.com/support/security-advisories/improper-input-validation-in-bitdefender-endpoint-security-tools-for-linux-va-9769
Get alerted when CVE-2021-3485 or the next vulnerability affects your stack