What’s Vulnerable › Vulnerabilities
CVE-2021-34876
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-13 · updated 2026-06-17
- Weakness: CWE-787
Description
This vulnerability allows remote attackers to execute arbitrary code on affected installations of Bentley View 10.15.0.75. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of JT files. Crafted data in a JT file can trigger a write past the end of an allocated buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-14828.
Affected products
- Bentley View: before 10.16.02 — fixed in 10.16.02
- Bentley MicroStation: before 10.16.02 — fixed in 10.16.02
How to fix
Upgrade to a fixed version: Bentley View 10.16.02; Bentley MicroStation 10.16.02. Check the vendor advisory for mitigations.
References
- https://www.bentley.com/en/common-vulnerability-exposure/BE-2021-0005
- https://www.zerodayinitiative.com/advisories/ZDI-21-1464/
- https://www.bentley.com/en/common-vulnerability-exposure/BE-2021-0005
- https://www.zerodayinitiative.com/advisories/ZDI-21-1464/
Get alerted when CVE-2021-34876 or the next vulnerability affects your stack