What’s Vulnerable › Vulnerabilities
CVE-2021-34884
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-13 · updated 2026-06-17
- Weakness: CWE-416
Description
This vulnerability allows remote attackers to disclose sensitive information on affected installations of Bentley View 10.15.0.75. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of JP2 files. The issue results from the lack of validating the existence of an object prior to performing operations on the object. An attacker can leverage this in conjunction with other vulnerabilities to execute arbitrary code in the context of the current process. Was ZDI-CAN-14837.
Affected products
- Bentley View: before 10.16.02 — fixed in 10.16.02
- Bentley MicroStation: before 10.16.02 — fixed in 10.16.02
How to fix
Upgrade to a fixed version: Bentley View 10.16.02; Bentley MicroStation 10.16.02. Check the vendor advisory for mitigations.
References
- https://www.bentley.com/en/common-vulnerability-exposure/BE-2021-0008
- https://www.zerodayinitiative.com/advisories/ZDI-21-1473/
- https://www.bentley.com/en/common-vulnerability-exposure/BE-2021-0008
- https://www.zerodayinitiative.com/advisories/ZDI-21-1473/
Get alerted when CVE-2021-34884 or the next vulnerability affects your stack