What’s Vulnerable › Vulnerabilities
CVE-2021-3493: Linux Kernel Privilege Escalation Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-10-20
- EPSS: 49.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-17 · updated 2026-06-17
- Weakness: CWE-270
Description
The overlayfs implementation in the linux kernel did not properly validate with respect to user namespaces the setting of file capabilities on files in an underlying file system. Due to the combination of unprivileged user namespaces along with a patch carried in the Ubuntu kernel to allow unprivileged overlay mounts, an attacker could use this to gain elevated privileges.
Affected products
- Canonical Ubuntu Linux: before 18.04; from 18.04.1 before 20.04; before 20.10 — fixed in 18.04, 20.04, 20.10
How to fix
Upgrade to a fixed version: Canonical Ubuntu Linux 18.04, 20.04, 20.10. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/162434/Kernel-Live-Patch-Security-Notice-LSN-0076-1.html
- http://packetstormsecurity.com/files/162866/Ubuntu-OverlayFS-Local-Privilege-Escalation.html
- http://packetstormsecurity.com/files/165151/Ubuntu-Overlayfs-Local-Privilege-Escalation.html
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=7c03e2cda4a584cadc398e8f6641ca9988a39d52
- https://ubuntu.com/security/notices/USN-4917-1
- https://www.openwall.com/lists/oss-security/2021/04/16/1
- http://packetstormsecurity.com/files/162434/Kernel-Live-Patch-Security-Notice-LSN-0076-1.html
- http://packetstormsecurity.com/files/162866/Ubuntu-OverlayFS-Local-Privilege-Escalation.html
- http://packetstormsecurity.com/files/165151/Ubuntu-Overlayfs-Local-Privilege-Escalation.html
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=7c03e2cda4a584cadc398e8f6641ca9988a39d52
- https://ubuntu.com/security/notices/USN-4917-1
- https://www.openwall.com/lists/oss-security/2021/04/16/1
Get alerted when CVE-2021-3493 or the next vulnerability affects your stack