What’s Vulnerable › Vulnerabilities
CVE-2021-34945
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-13 · updated 2026-06-17
- Weakness: CWE-122
Description
This vulnerability allows remote attackers to execute arbitrary code on affected installations of Bentley View 10.15.0.75. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of JT files. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a heap-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-15054.
Affected products
- Bentley View: before 10.16.02 — fixed in 10.16.02
- Bentley MicroStation: before 10.16.02 — fixed in 10.16.02
How to fix
Upgrade to a fixed version: Bentley View 10.16.02; Bentley MicroStation 10.16.02. Check the vendor advisory for mitigations.
References
- https://www.bentley.com/en/common-vulnerability-exposure/BE-2021-0005
- https://www.zerodayinitiative.com/advisories/ZDI-21-1533/
- https://www.bentley.com/en/common-vulnerability-exposure/BE-2021-0005
- https://www.zerodayinitiative.com/advisories/ZDI-21-1533/
Get alerted when CVE-2021-34945 or the next vulnerability affects your stack