What’s Vulnerable › Vulnerabilities
CVE-2021-34947: NETGEAR R7800 net-cgi Out-Of-Bounds Write Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-07 · updated 2026-06-17
- Weakness: CWE-787
Description
NETGEAR R7800 net-cgi Out-Of-Bounds Write Remote Code Execution Vulnerability. This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of NETGEAR R7800 routers. Authentication is not required to exploit this vulnerability. The specific flaw exists within the parsing of the soap_block_table file. The issue results from the lack of proper validation of user-supplied data, which can result in a write past the end of an allocated data structure. An attacker can leverage this vulnerability to execute code in the context of root. . Was ZDI-CAN-13055.
Affected products
- NETGEAR D7800 Firmware: before 1.0.1.64 — fixed in 1.0.1.64
- NETGEAR Ex2700 Firmware: before 1.0.1.66 — fixed in 1.0.1.66
- Netgear EX6100: before 1.0.1.106 — fixed in 1.0.1.106
- Netgear EX6150: before 1.0.1.106 — fixed in 1.0.1.106
- Netgear EX6200: before 1.0.1.86 — fixed in 1.0.1.86
- NETGEAR Ex6250 Firmware: before 1.0.0.146 — fixed in 1.0.0.146
- NETGEAR Ex6400 Firmware: before 1.0.2.164 — fixed in 1.0.2.164
- NETGEAR Ex6400V2 Firmware: before 1.0.0.146 — fixed in 1.0.0.146
- NETGEAR Ex6410 Firmware: before 1.0.0.146 — fixed in 1.0.0.146
- NETGEAR Ex6420 Firmware: before 1.0.0.146 — fixed in 1.0.0.146
- NETGEAR Ex6500V1 Firmware: before 1.0.0.146 — fixed in 1.0.0.146
- NETGEAR Ex7300 Firmware: before 1.0.2.164 — fixed in 1.0.2.164
- NETGEAR Ex7300V2 Firmware: before 1.0.0.146 — fixed in 1.0.0.146
- NETGEAR Ex7320 Firmware: before 1.0.0.146 — fixed in 1.0.0.146
- NETGEAR Ex7700 Firmware: before 1.0.0.222 — fixed in 1.0.0.222
- NETGEAR Ex8000 Firmware: before 1.0.1.238 — fixed in 1.0.1.238
- NETGEAR Lbr1020 Firmware: before 2.6.5.32 — fixed in 2.6.5.32
- NETGEAR Lbr20 Firmware: before 2.6.5.32 — fixed in 2.6.5.32
- NETGEAR R6700Ax Firmware: before 1.0.5.108 — fixed in 1.0.5.108
- NETGEAR R7800 Firmware: before 1.0.2.84 — fixed in 1.0.2.84
- NETGEAR R8900 Firmware: before 1.0.5.36 — fixed in 1.0.5.36
- NETGEAR R9000 Firmware: before 1.0.5.36 — fixed in 1.0.5.36
- NETGEAR Rax10 Firmware: before 1.0.5.108 — fixed in 1.0.5.108
- NETGEAR Rax120 Firmware: before 1.2.2.24 — fixed in 1.2.2.24
- NETGEAR Rax120V2 Firmware: before 1.2.2.24 — fixed in 1.2.2.24
- NETGEAR Rax70 Firmware: before 1.0.5.108 — fixed in 1.0.5.108
- NETGEAR Rax78 Firmware: before 1.0.5.108 — fixed in 1.0.5.108
- NETGEAR Rbr10 Firmware: before 2.7.4.24 — fixed in 2.7.4.24
- NETGEAR Rbr20 Firmware: before 2.7.4.24 — fixed in 2.7.4.24
- NETGEAR Rbr40 Firmware: before 2.7.4.24 — fixed in 2.7.4.24
How to fix
Upgrade to a fixed version: NETGEAR D7800 Firmware 1.0.1.64; NETGEAR Ex2700 Firmware 1.0.1.66; Netgear EX6100 1.0.1.106; Netgear EX6150 1.0.1.106; Netgear EX6200 1.0.1.86; NETGEAR Ex6250 Firmware 1.0.0.146; NETGEAR Ex6400 Firmware 1.0.2.164; NETGEAR Ex6400V2 Firmware 1.0.0.146; NETGEAR Ex6410 Firmware 1.0.0.146; NETGEAR Ex6420 Firmware 1.0.0.146; NETGEAR Ex6500V1 Firmware 1.0.0.146; NETGEAR Ex7300 Firmware 1.0.2.164. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000064044/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Some-Routers-PSV-2021-0129
- https://www.zerodayinitiative.com/advisories/ZDI-21-1116/
- https://kb.netgear.com/000064044/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Some-Routers-PSV-2021-0129
- https://www.zerodayinitiative.com/advisories/ZDI-21-1116/
Get alerted when CVE-2021-34947 or the next vulnerability affects your stack