What’s Vulnerable › Vulnerabilities
CVE-2021-3495
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-01 · updated 2026-06-17
- Weakness: CWE-281
Description
An incorrect access control flaw was found in the kiali-operator in versions before 1.33.0 and before 1.24.7. This flaw allows an attacker with a basic level of access to the cluster (to deploy a kiali operand) to use this vulnerability and deploy a given image to anywhere in the cluster, potentially gaining access to privileged service account tokens. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Affected products
- netlify Kiali-Operator: before 1.24.7; from 1.30.0 before 1.33.0 — fixed in 1.24.7, 1.33.0
- Red Hat OpenShift Service Mesh 2: 1.0, 2.0
How to fix
Upgrade to a fixed version: netlify Kiali-Operator 1.24.7, 1.33.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1947361
- https://kiali.io/news/security-bulletins/kiali-security-003/
- https://bugzilla.redhat.com/show_bug.cgi?id=1947361
- https://kiali.io/news/security-bulletins/kiali-security-003/
Get alerted when CVE-2021-3495 or the next vulnerability affects your stack