What’s Vulnerable › Vulnerabilities
CVE-2021-3497
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-19 · updated 2026-06-17
- Weakness: CWE-416
Description
GStreamer before 1.18.4 might access already-freed memory in error code paths when demuxing certain malformed Matroska files.
Affected products
- Debian Linux: 9.0, 10.0
- GStreamer: from 0.10.0 before 1.18.4 — fixed in 1.18.4
- Red Hat Enterprise Linux: 7.0, 8.0
How to fix
Upgrade to a fixed version: GStreamer 1.18.4. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1945339
- https://gstreamer.freedesktop.org/security/sa-2021-0002.html
- https://lists.debian.org/debian-lts-announce/2021/04/msg00027.html
- https://security.gentoo.org/glsa/202208-31
- https://www.debian.org/security/2021/dsa-4900
- https://bugzilla.redhat.com/show_bug.cgi?id=1945339
- https://gstreamer.freedesktop.org/security/sa-2021-0002.html
- https://lists.debian.org/debian-lts-announce/2021/04/msg00027.html
- https://security.gentoo.org/glsa/202208-31
- https://www.debian.org/security/2021/dsa-4900
Get alerted when CVE-2021-3497 or the next vulnerability affects your stack