What’s Vulnerable › Vulnerabilities
CVE-2021-3498
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-19 · updated 2026-06-17
- Weakness: CWE-119
Description
GStreamer before 1.18.4 might cause heap corruption when parsing certain malformed Matroska files.
Affected products
- Debian Linux: 10.0
- GStreamer: from 1.0.0 before 1.18.4 — fixed in 1.18.4
- Red Hat Enterprise Linux: 7.0, 8.0
How to fix
Upgrade to a fixed version: GStreamer 1.18.4. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/162952/Gstreamer-Matroska-Demuxing-Use-After-Free.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1945342
- https://gstreamer.freedesktop.org/security/sa-2021-0003.html
- https://security.gentoo.org/glsa/202208-31
- https://www.debian.org/security/2021/dsa-4900
- http://packetstormsecurity.com/files/162952/Gstreamer-Matroska-Demuxing-Use-After-Free.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1945342
- https://gstreamer.freedesktop.org/security/sa-2021-0003.html
- https://security.gentoo.org/glsa/202208-31
- https://www.debian.org/security/2021/dsa-4900
Get alerted when CVE-2021-3498 or the next vulnerability affects your stack