What’s Vulnerable › Vulnerabilities
CVE-2021-34982: NETGEAR Multiple Routers httpd Stack-based Buffer Overflow Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-07 · updated 2026-06-17
- Weakness: CWE-121
Description
NETGEAR Multiple Routers httpd Stack-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of multiple NETGEAR routers. Authentication is not required to exploit this vulnerability. The specific flaw exists within the httpd service, which listens on TCP port 80 by default. When parsing the strings file, the process does not properly validate the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of root. . Was ZDI-CAN-13709.
Affected products
- NETGEAR D6220 Firmware: before 1.0.0.76 — fixed in 1.0.0.76
- Netgear D6400: before 1.0.0.108 — fixed in 1.0.0.108
- NETGEAR D7000V2 Firmware: before 1.0.0.76 — fixed in 1.0.0.76
- NETGEAR Dc112A Firmware: before 1.0.0.62 — fixed in 1.0.0.62
- NETGEAR Dgn2200V4 Firmware: before 1.0.0.126 — fixed in 1.0.0.126
- NETGEAR EX3700: before 1.0.0.94 — fixed in 1.0.0.94
- NETGEAR Ex3800 Firmware: before 1.0.0.94 — fixed in 1.0.0.94
- NETGEAR EX6120: before 1.0.0.66 — fixed in 1.0.0.66
- NETGEAR Ex6130 Firmware: before 1.0.0.46 — fixed in 1.0.0.46
- NETGEAR Ex7000 Firmware: before 1.0.1.106 — fixed in 1.0.1.106
- NETGEAR Ex7500 Firmware: before 1.0.1.76 — fixed in 1.0.1.76
- NETGEAR Lax20 Firmware: before 1.1.6.30 — fixed in 1.1.6.30
- NETGEAR Mr60 Firmware: before 1.1.6.122 — fixed in 1.1.6.122
- NETGEAR Mr80 Firmware: before 1.1.6.10 — fixed in 1.1.6.10
- NETGEAR Ms60 Firmware: before 1.1.6.122 — fixed in 1.1.6.122
- NETGEAR Ms80 Firmware: before 1.1.6.10 — fixed in 1.1.6.10
- NETGEAR R6400 Firmware: before 1.0.1.76 — fixed in 1.0.1.76
- NETGEAR R6400V2 Firmware: before 1.0.4.120 — fixed in 1.0.4.120
- NETGEAR R6700V3 Firmware: before 1.0.4.120 — fixed in 1.0.4.120
- NETGEAR R6900P Firmware: before 1.3.3.148 — fixed in 1.3.3.148
- NETGEAR R7000: before 1.0.11.128 — fixed in 1.0.11.128
- NETGEAR R7000P: before 1.3.3.148 — fixed in 1.3.3.148
- NETGEAR R7100Lg Firmware: before 1.0.0.72 — fixed in 1.0.0.72
- NETGEAR R7850 Firmware: before 1.0.5.76 — fixed in 1.0.5.76
- NETGEAR R7900P Firmware: before 1.4.2.84 — fixed in 1.4.2.84
- NETGEAR R7960P Firmware: before 1.4.2.84 — fixed in 1.4.2.84
- NETGEAR R8000 Firmware: before 1.0.4.76 — fixed in 1.0.4.76
- NETGEAR R8000P Firmware: before 1.4.2.84 — fixed in 1.4.2.84
- NETGEAR R8300 Firmware: before 1.0.2.156 — fixed in 1.0.2.156
- NETGEAR R8500 Firmware: before 1.0.2.156 — fixed in 1.0.2.156
How to fix
Upgrade to a fixed version: NETGEAR D6220 Firmware 1.0.0.76; Netgear D6400 1.0.0.108; NETGEAR D7000V2 Firmware 1.0.0.76; NETGEAR Dc112A Firmware 1.0.0.62; NETGEAR Dgn2200V4 Firmware 1.0.0.126; NETGEAR EX3700 1.0.0.94; NETGEAR Ex3800 Firmware 1.0.0.94; NETGEAR EX6120 1.0.0.66; NETGEAR Ex6130 Firmware 1.0.0.46; NETGEAR Ex7000 Firmware 1.0.1.106; NETGEAR Ex7500 Firmware 1.0.1.76; NETGEAR Lax20 Firmware 1.1.6.30. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000064313/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Some-Extenders-Routers-and-DSL-Modem-Routers-PSV-2021-0159
- https://www.zerodayinitiative.com/advisories/ZDI-21-1274/
- https://kb.netgear.com/000064313/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Some-Extenders-Routers-and-DSL-Modem-Routers-PSV-2021-0159
- https://www.zerodayinitiative.com/advisories/ZDI-21-1274/
Get alerted when CVE-2021-34982 or the next vulnerability affects your stack