What’s Vulnerable › Vulnerabilities
CVE-2021-35005
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-24 · updated 2026-06-17
- Weakness: CWE-129
Description
This vulnerability allows local attackers to disclose sensitive information on affected installations of TeamViewer. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability. The specific flaw exists within the TeamViewer service. The issue results from the lack of proper validation of user-supplied data, which can result in a read past the end of an allocated array. An attacker can leverage this in conjunction with other vulnerabilities to execute arbitrary code in the context of SYSTEM. Was ZDI-CAN-13818.
Affected products
- TeamViewer: before 15.18.5.0 — fixed in 15.18.5.0
How to fix
Upgrade to a fixed version: TeamViewer 15.18.5.0. Check the vendor advisory for mitigations.
References
- https://community.teamviewer.com/English/discussion/117794/august-updates-security-patches
- https://www.zerodayinitiative.com/advisories/ZDI-22-082/
- https://community.teamviewer.com/English/discussion/117794/august-updates-security-patches
- https://www.zerodayinitiative.com/advisories/ZDI-22-082/
Get alerted when CVE-2021-35005 or the next vulnerability affects your stack