What’s Vulnerable › Vulnerabilities
CVE-2021-35031
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-28 · updated 2026-06-17
- Weakness: CWE-78
Description
A vulnerability in the TFTP client of Zyxel GS1900 series firmware, XGS1210 series firmware, and XGS1250 series firmware, which could allow an authenticated LAN user to execute arbitrary OS commands via the GUI of the vulnerable device.
Affected products
- Zyxel GS1900-10HP firmware: before 2.70\(aazi.0\)-20211208 — fixed in 2.70\(aazi.0\)-20211208
- Zyxel GS1900-16 firmware: before 2.70\(aahj.0\)-20211208 — fixed in 2.70\(aahj.0\)-20211208
- Zyxel GS1900-24 firmware: before 2.70\(aahl.0\)-20211208 — fixed in 2.70\(aahl.0\)-20211208
- Zyxel GS1900-24E firmware: before 2.70\(aahk.0\)-20211208 — fixed in 2.70\(aahk.0\)-20211208
- Zyxel GS1900-24EP firmware: before 2.70\(abto.0\)-20211208 — fixed in 2.70\(abto.0\)-20211208
- Zyxel Gs1900-24Hp Firmware: before 2.70\(aahm.0\)-20211208 — fixed in 2.70\(aahm.0\)-20211208
- Zyxel GS1900-24HPv2 firmware: before 2.70\(aatp.0\)-20211208 — fixed in 2.70\(aatp.0\)-20211208
- Zyxel GS1900-48 firmware: before 2.70\(aahn.0\)-20211208 — fixed in 2.70\(aahn.0\)-20211208
- Zyxel Gs1900-48Hp Firmware: before 2.70\(aaho.0\)-20211208 — fixed in 2.70\(aaho.0\)-20211208
- Zyxel GS1900-48HPv2 firmware: before 2.70\(abtq.0\)-20211208 — fixed in 2.70\(abtq.0\)-20211208
- Zyxel GS1900-8 firmware: before 2.70\(aahh.0\)-20211208 — fixed in 2.70\(aahh.0\)-20211208
- Zyxel GS1900-8HP firmware: before 2.70\(aahi.0\)-20211208 — fixed in 2.70\(aahi.0\)-20211208
- Zyxel Xgs1210-12 Firmware: before 1.00\(abty.5\)c0 — fixed in 1.00\(abty.5\)c0
- Zyxel Xgs1250-12 Firmware: before 1.00\(abwe.1\)c0 — fixed in 1.00\(abwe.1\)c0
How to fix
Upgrade to a fixed version: Zyxel GS1900-10HP firmware 2.70\(aazi.0\)-20211208; Zyxel GS1900-16 firmware 2.70\(aahj.0\)-20211208; Zyxel GS1900-24 firmware 2.70\(aahl.0\)-20211208; Zyxel GS1900-24E firmware 2.70\(aahk.0\)-20211208; Zyxel GS1900-24EP firmware 2.70\(abto.0\)-20211208; Zyxel Gs1900-24Hp Firmware 2.70\(aahm.0\)-20211208; Zyxel GS1900-24HPv2 firmware 2.70\(aatp.0\)-20211208; Zyxel GS1900-48 firmware 2.70\(aahn.0\)-20211208; Zyxel Gs1900-48Hp Firmware 2.70\(aaho.0\)-20211208; Zyxel GS1900-48HPv2 firmware 2.70\(abtq.0\)-20211208; Zyxel GS1900-8 firmware 2.70\(aahh.0\)-20211208; Zyxel GS1900-8HP firmware 2.70\(aahi.0\)-20211208. Check the vendor advisory for mitigations.
References
- https://www.zyxel.com/support/Zyxel_security_advisory_for_OS_command_injection_vulnerabilities_of_switches.shtml
- https://www.zyxel.com/support/Zyxel_security_advisory_for_OS_command_injection_vulnerabilities_of_switches.shtml
Get alerted when CVE-2021-35031 or the next vulnerability affects your stack