What’s Vulnerable › Vulnerabilities
CVE-2021-35034
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-29 · updated 2026-06-17
- Weakness: CWE-613
Description
An insufficient session expiration vulnerability in the CGI program of the Zyxel NBG6604 firmware could allow a remote attacker to access the device if the correct token can be intercepted.
Affected products
- Zyxel NBG6604 firmware: before 1.00\(abir.9\)c0 — fixed in 1.00\(abir.9\)c0
How to fix
Upgrade to a fixed version: Zyxel NBG6604 firmware 1.00\(abir.9\)c0. Check the vendor advisory for mitigations.
References
- https://www.zyxel.com/support/Zyxel_security_advisory_for_sensitive_information_vulnerabilities_of_NBG6604_home_router.shtml
- https://www.zyxel.com/support/Zyxel_security_advisory_for_sensitive_information_vulnerabilities_of_NBG6604_home_router.shtml
Get alerted when CVE-2021-35034 or the next vulnerability affects your stack