What’s Vulnerable › Vulnerabilities
CVE-2021-35047: Privileged Command Injection Vulnerability in Fidelis Network and Deception
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-25 · updated 2026-06-17
- Weakness: CWE-78
Description
Vulnerability in the CommandPost, Collector, and Sensor components of Fidelis Network and Deception enables an attacker with user level access to the CLI to inject root level commands into the component and neighboring Fidelis components. The vulnerability is present in Fidelis Network and Deception versions prior to 9.3.7 and in version 9.4. Patches and updates are available to address this vulnerability.
Affected products
- Fidelissecurity Deception: before 9.3.7; 9.4 — fixed in 9.3.7
- Fidelissecurity Network: before 9.3.7; 9.4 — fixed in 9.3.7
How to fix
Upgrade to a fixed version: Fidelissecurity Deception 9.3.7; Fidelissecurity Network 9.3.7. Check the vendor advisory for mitigations.
References
- https://support.fidelissecurity.com/hc/en-us/categories/360001842694-Advisories-News-and-Policies
- https://www.securifera.com/blog/2021/06/24/operation-eagle-eye/
- https://support.fidelissecurity.com/hc/en-us/categories/360001842694-Advisories-News-and-Policies
- https://www.securifera.com/blog/2021/06/24/operation-eagle-eye/
Get alerted when CVE-2021-35047 or the next vulnerability affects your stack