What’s Vulnerable › Vulnerabilities
CVE-2021-3523
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-27 · updated 2026-06-17
- Weakness: CWE-281
Description
A flaw was found in 3Scale APICast in versions prior to 2.11.0, where it incorrectly identified connections for reuse. This flaw allows an attacker to bypass security restrictions for an API request when hosting multiple APIs on the same IP address.
Affected products
- apicast: before 2.11.0 — fixed in 2.11.0
How to fix
Upgrade to a fixed version: apicast 2.11.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1954805
- https://bugzilla.redhat.com/show_bug.cgi?id=1954805
Get alerted when CVE-2021-3523 or the next vulnerability affects your stack