What’s Vulnerable › Vulnerabilities
CVE-2021-3528
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-13 · updated 2026-06-17
- Weakness: CWE-522
Description
A flaw was found in noobaa-operator in versions before 5.7.0, where internal RPC AuthTokens between the noobaa operator and the noobaa core are leaked into log files. An attacker with access to the log files could use this AuthToken to gain additional access into noobaa deployment and can read/modify system configuration.
Affected products
- NooBaa: before 5.7.0 — fixed in 5.7.0
How to fix
Upgrade to a fixed version: NooBaa 5.7.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1955601
- https://bugzilla.redhat.com/show_bug.cgi?id=1955601
Get alerted when CVE-2021-3528 or the next vulnerability affects your stack