What’s Vulnerable › Vulnerabilities
CVE-2021-35513
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Mermaid before 8.11.0 allows XSS when the antiscript feature is used.
Affected products
- mermaid-js mermaid: before 8.11.0 — fixed in 8.11.0
How to fix
Upgrade to a fixed version: mermaid-js mermaid 8.11.0. Check the vendor advisory for mitigations.
References
- https://github.com/mermaid-js/mermaid/issues/2122
- https://github.com/mermaid-js/mermaid/pull/2123
- https://github.com/mermaid-js/mermaid/releases/tag/8.11.0-rc2
- https://github.com/mermaid-js/mermaid/issues/2122
- https://github.com/mermaid-js/mermaid/pull/2123
- https://github.com/mermaid-js/mermaid/releases/tag/8.11.0-rc2
Get alerted when CVE-2021-35513 or the next vulnerability affects your stack